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B iB iBasicBasic

C1) Correct Journal Entries

2) Drilldown with Account Rollups

3) Use Quick and Dirty Deferrals with 
Recurring Batchesg

4) Use Account Aliases4) Use Account Aliases



Correct Journal Entries
Reverse and Replace a Journal Entry using functionality found in 
Transactions>Financial>General>Correct.
Details at: http://msdynamicsgp.blogspot.com/2005/09/weekly-feature-extreme-makeover-
j ht lje.html

Drilldown with Account Rollups
Account Rollups let you consolidate information from various accounts and then be able to drill 
down into the account details.
Useful for things like departmental totals with drilldownsUseful for things like departmental totals with drilldowns.
Accounts do not have to be consecutive.
Rollups can include Actual, Budget and Calculated information.
Details at: http://msdynamicsgp.blogspot.com/2005/09/weekly-feature-account-rollup.html

Use Quick and Dirty Deferrals with Recurring BatchesQ y g
For a large number of deferrals, Revenue/Expense Deferrals or Contracts are a better solution.
For a small number of deferrals, post the transaction to a deferral account and use Recurring 
GL Batches to recognize the deferred amount.
One batch per transaction.
Put an underscore (_) or a “z” at the beginning of the batch to move all deferred batches to the 
top or bottom of the batch list respectively.

Use Account Aliases
Account Aliases are shortcut names for accounts and are setup in Cards->Financial>Account.
In transactions instead of entering an account click the blue arrow next to the account title andIn transactions, instead of entering an account, click the blue arrow next to the account title and 
enter the alias.
More info here: http://msdynamicsgp.blogspot.com/2008/03/weekly-dynamics-use-account-
alias-when.htmlNEXT: <General Ledger Intermediate>



I t di tI t di tIntermediateIntermediate

5. Duplicate a Journal Entry

6 Check Posting Types Before Year End6. Check Posting Types Before Year End

7. Speed Bank Transfers with a Macro7. Speed Bank Transfers with a Macro

8. Get Consistent Account Descriptions

9. Reconcile the Bank Account Daily



Duplicate a Journal Entry
Use the Correct Journal Entry info in tip 1 to create a reversing Journal Entry and a new copy.
Delete the reversing entry. Now you have a perfect copy that can be adjusted as necessary.
Details here: http://msdynamicsgp.blogspot.com/2008/11/weekly-dynamic-duplicate-journal-entry.html

Check Posting Types before Year End
It’s important to validate that Posting Type (Balance Sheet or Profit & Loss) is correct at year endIt s important to validate that Posting Type (Balance Sheet or Profit & Loss) is correct at year end.
A simple SmartList can show items in the wrong Posting Type.
Use the search feature to limit account numbers to Balance Sheet numbers and set Posting Type to Profit and Loss. This 
will show misclassified Balance Sheet Accounts.
Reverse to show misclassified P&L accounts.
More Info here: http://msdynamicsgp.blogspot.com/2006/12/weekly-dynamic-check-account-posting.htmlp y gp g p y y p g

Speed Bank transfers with a Macro
Bank transfers are often repetitive with only the date and amount changing (from operating to payroll, from money market 
to operating, etc.)
They offer a great starting point to learn about GP Macros.
Details here: http://msdynamicsgp.blogspot.com/2005/11/weekly-feature-macro-basics.html

Get Consistent Account DescriptionsGet Consistent Account Descriptions
Don’t setup accounts first, setup Segments in Tools->Setup->Financial->Segment. 
Creating accounts will then auto populate the description based on the Segment descriptions.
This gives consistent chart descriptions and a warning when a segment doesn’t exist.
Find out more at: http://msdynamicsgp.blogspot.com/2006/07/weekly-dynamicauto-populate-account.html

Reconcile Bank Account DailyReconcile Bank Account Daily
With today’s internet access, there is no reason not to balance the bank account daily.
Daily balancing provides up to date cash position, float information and speeds month end processing since bank 
balancing is simply one more day.
Download your bank info from your bank’s website.
Start a bank reconciliation and reconcile it to zero.
DON’T push the reconcile button. Save the reconciliation and come back tomorrow.
Help here: http://msdynamicsgp.blogspot.com/2006/03/weekly-dynamic-best-practice-daily.html

NEXT: <General Ledger Advanced>



Ad dAd dAdvancedAdvanced

S f10)Speed Up the Population of Journal Entry 
numbers on the Correct Journal Entry 
ScreenScreen

T A D i i N ifi i11)Turn on Account Description Notifications



Speed up the Population of the JE numbers on the Correct Journal Entry 
Screen

Looking up Journal Entry corrections is slow because of the number ofLooking up Journal Entry corrections is slow because of the number of 
transactions.
GP provides an index for that table that can speed lookups.
KB 925326 contains a small SQL Script to apply a non-clustered index to p pp y
the GL20000 and GL30000 tables and this solves the problem. 
KB article is located here: 
https://mbs.microsoft.com/knowledgebase/KBDisplay.aspx?WTNTZSMN
WUKNTMMYKORSXPPNNWUNVVRWVWKNTNUKQZPXMSVKKVLKYWUKNTMMYKORSXPPNNWUNVVRWVWKNTNUKQZPXMSVKKVLKY
QWQQQQTQLWR

Turn on Account Description Notifications
Segment notifications in tip 8 can be turned off by user with a check box. 
You need a SQL Script to turn them back on
The script is here: http://msdynamicsgp.blogspot.com/2006/11/weekly-
dynamic-account-description.html

NEXT: <Purchasing and Inventory Basic>



B iB iBasicBasic

12)Prioritize Your Vendors

13)Track Use Tax for Purchase Orders



Prioritize Your Vendors
Payables Management includes a 3 digit alphanumeric field used to prioritize vendors.
A simple ABC is generally more effective than a bunch of 3 digit numbers. For example, A could 
be used for highest priority vendors like a newsprint supplier for a newspaper.
U thi t ti l d id hi h d iti l t h i i hitUse this to actively decide which vendors are critical now, not when a crisis hits.
This field can be used to select vendors during the check selection process.

Track use Tax for P.O.'s
If you are not charged sales tax by a vendor and need to self-remit use tax for a P.O. use these 
steps:steps:

Let the system calculate Sales Tax.
Offset the tax amount in the Trade Discount field.
Point the trade discount field to an accrued use tax account.
Point the sales tax field to the appropriate expense or tax account.pp p p
Vendor gets paid properly because of the credit and tax gets recorded.
Use SmartLists to track and report use tax data for later remittance.

NEXT: < Purchasing and Inventory Intermediate>



I t di tI t di tIntermediateIntermediate

14)Track Use Tax in Accounts Payable

15)Track Use Tax in Purchase Orders (Opt 2)15)Track Use Tax in Purchase Orders (Opt. 2)

16)Use the New Historical Inventory Trial16)Use the New Historical Inventory Trial 
Balance to Balance

17)Copy an Inventory Item

18)Copy a Purchase Order18)Copy a Purchase Order



Track  Use Tax in AP
Use tax can be tracked for purchases made via AP.
Setup a Credit Card in GP for each Use Tax jurisdiction and link it to the vendor account for that taxing authority.Setup a Credit Card in GP for each Use Tax jurisdiction and link it to the vendor account for that taxing authority.
Enter a voucher in AP and let GP calculate the tax.
Pay just the tax amount using the Tax Authority credit card. 
This creates a liability in AP to the Taxing Authority for future payment.
Vendor gets paid correct amount and correct amount shows on vendor record.
Details here: http://msdynamicsgp.blogspot.com/2007/09/weekly-dynamic-use-tax-in-payables.html

Track use tax in P O ’s (Option 2)Track use tax in P.O. s (Option 2)
Enter P.O., Receipt and Invoice. 
Make a payment on the Invoice form using a Taxing Authority credit card like the one created in tip 14.
Liability gets created in AP to Taxing Authority for future payment.
Vendor record holds correct amount.

Use the new Historical Inventory Trial Balance report
The new Historical Inventory Trial Balance (HITB) report is designed to help balance inventory to the GL regardless of the inventoryThe new Historical Inventory Trial Balance (HITB) report is designed to help balance inventory to the GL regardless of the inventory 
valuation method.
It is available with GP 10 Feature Pack 1

Copy an Inventory Item
Cards->Inventory->Item, Enter new item number and click copy
Select parts of an item to copy and press copy.
More info here http://msdynamicsgp.blogspot.com/2008/11/weekly-dynamic-copy-inventory-item.html

Copy a Purchase Order
Transactions->Purchasing->Purchase Order Entry, Actions->Create->Copy New PO
Select parts/lines to copy and press Copy
More info at http://msdynamicsgp.blogspot.com/2008/12/weekly-dynamic-copy-po.html

NEXT: <Sales Basic>



B iB iBasicBasic

C19)Add Invoice Notes as Comments Without a 
Comment ID

20)Deliver the Goods with Mapping

21)Review Customer Terms)



Add Invoice Notes as Comments Without a Comment ID
Comments were originally intended to be reusable so they include a comment ID, but most 
companies don’t use them that waycompanies don t use them that way. 
To skip the ID, just hit the blue arrow and add your comment.
An indicator turns on to show you that there is a comment.
Comments print on default quotes, orders and invoices without customization.
Info here: http://msdynamicsgp.blogspot.com/2008/07/weekly-dynamic-comments-without-o e e ttp // sdy a csgp b ogspot co / 008/0 / ee y dy a c co e ts t out
comment.html

Deliver the goods with Mapping
In Sales Order Processing, the Push Pin Icon next to the address ID opens up a map of that 
location.
Th b t d i th i t t l ll if Mi ft M P i t i i t ll dThe map can be generated via the internet or locally if Microsoft Map Point is installed.
This is useful for pinpointing customer locations for delivery.
Detail here: http://msdynamicsgp.blogspot.com/2006/07/weekly-dynamic-map-functionality.html

Review Customer Terms
Use SmartLists to review and adjust Customer TermsUse SmartLists to review and adjust Customer Terms

NEXT: <Fixed Assets Basic>



B iB iBasicBasic

G C S22)Gain Clarity with Separate Depreciation 
Posting

23)Speed Up Month End by Posting 
D i i E liDepreciation Earlier

24)Retain Info by Printing Year-End Reports



Gain Clarity with Separate Depreciation Posting
P t D i ti t th GL t l f N A t d R ti tPost Depreciation to the GL separately from New Assets and Retirements.
Separating these allows easy review of Asset Additions/Retirement for correctness without 
having to wade through all of the depreciation posting entries.
Details here: http://msdynamicsgp.blogspot.com/2006/05/weekly-dynamicfixed-assetgl-
best.html

Speed up month end by posting depreciation sooner
If possible, switch your depreciation to start “Next Month”. Then you can run depreciation early 
in the month and not worry about new asset additions since they won’t start depreciating until 
next month.
If th t’ t ibl d i ti t th b i i f th thIf that’s not possible, run depreciation at the beginning of the month anyway.
Then run it again at month end. It will only pick up new assets and be very fast.
Benefits include visibility into depreciation throughout the month and faster month end 
processing by moving most of depreciation out of month end.

Retain info by Printing Year End ReportsRetain info by Printing Year End Reports
The Fixed Asset module’s biggest flaw is past years reporting.
Print FA reports at year end and keep them somewhere safe.
Consider printing a copy to an electronic file as well.

NEXT: <Fixed Assets Intermediate>



I t di tI t di tIntermediateIntermediate

C f25)Collect Tangible Property Tax Information

26)Find Fixed Asset Transaction Details



Collect tangible personal property tax information
L ti ID i Fi d A t i d i d t h ld t ibl l t t i f ti ItLocation ID in Fixed Assets is designed to hold tangible personal property tax information. It 
includes State, City and County fields. 
Enter this for all your assets and then you can use a SmartList to pull the basic information you 
need to start tangible personal property tax returns.
Details here: http://msdynamicsgp.blogspot.com/2007/12/tangible-personal-property-tax-in.htmlp y gp g p g p p p y

Find Fixed Asset Transaction Details
The Fixed Asset Financial Detail window is a view into an asset’s soul. Every FA transaction is 
shown in here including links back to the GL. 
If you don’t know what is going on with a Fixed Asset, this is the place to look.
More info here: http://msdynamicsgp.blogspot.com/2006/04/weekly-dynamic-putting-fix-in-
fixed.html

NEXT: <SmartList and Reporting Basic>



B iB iBasicBasic

S C27)Rename SmartList Columns

28)Impose Order with Multiple Sorts

29)Ease Printing with Report Groups



Rename SmartList Columns
If d ’t lik l ith lik ATYALLOC i S tLi t i l thIf you don’t like columns with names like ATYALLOC in your SmartList simply rename them.
Open a SmartList and click Columns. Change a column name in the Display Name column and 
save the SmartList as a favorite.
Information here: http://msdynamicsgp.blogspot.com/2006/06/weekly-dynamic-change-column-
titles-in.html

Impose Order with Multiple Sorts
SmartLists let you sort by clicking on a column title.
To sort by multiple columns, click Search then Order By and add columns to sort by.
Details here: http://msdynamicsgp.blogspot.com/2006/06/weekly-dynamic-change-column-
titles-in.html

Ease Printing with Report Groups
Report groups let you add multiple reports to a group and then print them all at once.
This is very useful for month end reports.
Pi k t d lik l O ti ill b Gi th d ddPick reports and an area like sales. One option will be groups. Give the group a name and add 
report options (named report settings)
It is best use settings like Beginning of Previous Month and End of Previous Month in the report 
options, otherwise you have to change all the dates and it defeats the purpose. 
Run the report group and you’re done.p g p y

NEXT: < SmartList and Reporting Intermediate>



I t di tI t di tIntermediateIntermediate

S S30)Limit Records to Speed SmartLists

31)Improve Lookups with Favorites

32)Let SmartList Alerts Warn You

33)Leverage the List View for Reporting



Limit Records to Speed SmartLists
SmartLists can have number of record limits set by default This is designed to improve performanceSmartLists can have number of record limits set by default. This is designed to improve performance.
Sometimes the limits are set too low and records get excluded. Sometimes they are too high and performance suffers.
You can fine tune this when you run a query in the search window or by default for a query in Tools->Setup->System-
>SmartList Options.
Details here: http://msdynamicsgp.blogspot.com/2008/09/weekly-dynamic-smarlist-record-limits.html

Improve lookups with Favorites
Some companies have a large chart of accounts where many employees only work with subset of accounts appropriate 
for their department. 
Build that subset into a SmartList using search to limit records.
Save that SmartList as a favorite.
When looking up accounts, pick Favorites and that favorite. Your pick list will now be limited to the accounts from the 
much smaller SmartList.much smaller SmartList.
More info here: http://msdynamicsgp.blogspot.com/2006/09/weekly-dynamic-using-favorites-in-your.html

Let SmartLists Alerts Warn You
You can build an alert off a SmartList to know when information falls outside your parameters.
Setup a SmartList. 
Save it as a Favorite by picking Favorite and Alert. 
Follow the wizard to setup an alert.
Details here: http://msdynamicsgp.blogspot.com/2006/05/weekly-dynamic-custom-reminders-from.html

Leverage the list view for reporting
List views are new in GP.
In reporting, they can provide all of the available reports in one place.
N h ti f th t i t t th t t b d th i ht h dNo more hunting for that inventory report that never seems to be under the right header.
Details here: http://msdynamicsgp.blogspot.com/2006/06/weekly-dynamic-report-lists-in-v9.html

NEXT: <SmartList and Reporting Advanced>
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34)Wow them with Excel Exports

35)Duplicate SmartLists with Builder

36)Free your Data with Excel Reporting

37)SmartLists + Excel Reports = Cool!



Blow their mind with advanced Excel Exports
SmartList has advanced export functionalitySmartList has advanced export functionality.
You can save Export details for a SmartList so that it always goes to the same file name, Excel Macros can run 
before and/or after the Export and it can be picked from the favorites list. 
Information here: http://msdynamicsgp.blogspot.com/2005/10/weekly-feature-excel-ing-with.html

Duplicate SmartLists with Builder
Need a SmartList that looks a lot like one you’ve already built in SmartList Builder? Don’t start from scratchNeed a SmartList that looks a lot like one you ve already built in SmartList Builder? Don t start from scratch.
Open the SmartList you built and hit Extras->Copy. Name and modify the copy and cut a ton of time off building 
that next SmartList.
Details here: http://msdynamicsgp.blogspot.com/2008/05/weekly-dynamic-copy-smartlist-builder.html

Free your data with the new Excel reports
New Excel Reports push live (meaning you can refresh it) data from GP to ExcelNew Excel Reports push live (meaning you can refresh it) data from GP to Excel.
Microsoft Office Sharepoint Server (MOSS) is not required, just a file share.
Lot of default reports, new one can be built with SmartList builder.
Details here: http://msdynamicsgp.blogspot.com/2008/03/weekly-dynamicexcel-reports-in-dynamics.html

SmartLists + Excel Reports = Cool!
New in SmartList Builder is the option to create your own Excel reportsNew in SmartList Builder is the option to create your own Excel reports.
Tools->SmartList Builder->Excel  Reports Builder. Build, click Publish
Built the same way as SmartList builder. 

NEXT: <System Basic>
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C S38)Check your Security

39)Get Some Help39)Get Some Help

40)Know Your Version)

41)Fix Auto Complete

42)Change Your Role

43)Warn About Test Companies



Check Your Security
There is a master security switch like the master breaker on your home. 
It’s in Tools >Setup >Company >Company It is a little security check boxIt s in Tools->Setup->Company->Company. It is a little security check box.
Make sure the box is checked and that people can’t access this window.
More info: http://msdynamicsgp.blogspot.com/2005/10/weekly-gotcha-that-little-security.html

Get Some Help
Ever wanted to know what a certain field does? Put your cursor in the field and hit the F1 key for help. 
In the main GP system, there is a “fields” hyperlink up top that takes you to a definition of every field on the window.y , yp p p y y
In some modules, there is no “fields” button, but field specifics are included in the main help window.

Know Your Version
When you contact GP support, you’ll need your version information including information about service packs. 
You can find everything you will need by clicking Help(?)->About

Fix Auto Complete
Auto Complete finishes your entries for you. 
It’s great until you misspell something and are stuck with it forever.
To get rid of it, start typing until the error shows up in Auto Complete. 
Right click and hit Remove from List.

Change your role
If your role has changed or you picked the wrong one when setting up GP for the first time you can easily change itIf your role has changed or you picked the wrong one when setting up GP for the first time you can easily change it.
Click Customize This Page->Change Roles.
Details here: http://msdynamicsgp.blogspot.com/2006/09/weekly-dynamic-change-your-role-on.html

Warn About Test Companies
Add <TEST> next to company name in GP.
Warning message will pop up when users log in.Warning message will pop up when users log in.
More info here: http://msdynamicsgp.blogspot.com/2008/10/activating-test-company-message.html

NEXT: <System Intermediate>
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44)Limit Auto Fill

45)Help Protect Yourself with Account Security45)Help Protect Yourself with Account Security

46)Connect with Custom Links)

47)Build a Quick and Dirty Workflow

48)Leverage Business Ready Licensing



Limit Auto Fill
Auto Fill default setting of 1,000 entries is per user, per field.
This can have a negative impact on performance over time.
Reduce this during user setup and set unused entries to clear after 60 days.
Details here: http://msdynamicsgp.blogspot.com/search?q=auto+fill

Protect yourself with Account Security
Account Security limits the accounts that users can access.
It requires setup via Organizational Structure.
If you don’t set up Organizational Structures prior to turning this on, it appears that the chart of accounts has been wiped out. This can be a career 
killerkiller.
Account Security is turned on with a check box in Tools->Setup->Company->Company.
Know what you are doing before activating this.
More info here: http://msdynamicsgp.blogspot.com/2008/07/weekly-dynamic-account-security.html

Connect with Custom Links
Custom links let you associate a web page with master records.
For example, you can associate a bank’s web page with a bank account.
Clicking on the bank account link now gives you an option to go to either the bank account setup or the bank’s web page.
Setup is done in Tools-Setup-Company-Custom Link.
Details here: http://msdynamicsgp.blogspot.com/2006/07/weekly-dynamiccustom-links.html

Build a Quick and Dirty Workflow
For simple workflows like check printing, create a folder in the navigation bar at the left.
Open the first window for a process and click File->Add to Shortcuts
Repeat this for each window in the processRepeat this for each window in the process.
At the end, you have a folder with all the windows for a process in sequence.
This works well for Month End processes as well.

Improve your system by Leveraging BRL
Business Ready Licensing provides a large number of available modules that many companies don’t effectively leverage.
Many modules are quickly implemented like EFT for AP, Electronic Reconcile and Collections Management.
Don’t leave functionality on the table. If you have pain in an area, see if there is something in BRL that can help.

NEXT: <System Advanced>
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50)Backup, Backup, Backup



Roll Down Service Packs
Service packs can be rolled down from a central location starting with version 9. 
Specifics here: http://msdynamicsgp.blogspot.com/2006/07/weekly-dynamic-rolling-down-
service.html

B k B k B kBackup, Backup, Backup
The built in backup functionality in GP is better than nothing. If you are not backing up, use this 
now!
This won’t get everything. You still need to backup custom reports and forms, the Integration 
Manager database and FRx reports but backing up the database is a start.g p g p
Details here: http://msdynamicsgp.blogspot.com/2008/04/new-msdynamicsworld-article-on-
gp.html and here: http://msdynamicsgp.blogspot.com/2006/05/weekly-dynamic-schedule-
backups-in-90.html

NEXT: <Microsoft Ending Slide>
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• Fill out your evaluation please!
• Follow up PowerPoint Deck has lots of 

d il d li k f i f idetail and links for more information
• Contact us

• Mark Polino
• mpolino@ibisinc.com

htt // D i A ti t• http://www.DynamicAccounting.net
• Pam Misialek

• Pam Misialek@microsoft comPam.Misialek@microsoft.com
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